Mantis - obex-data-server
Расширенный вид
223 General нововведение неприменима 2009-11-10 10:27 2013-03-29 01:38
skirsdeda  
 
обычный  
новый 0.4.5  
открыт  
нет    
нет  
0000223: Not possible to change timeout period
It should be possible to change timeout period. Not sure if it should be done globally with configure or possible to change at runtime as well...
история
2009-11-10 10:27 skirsdeda Новый вопрос
2009-11-10 10:27 skirsdeda Целевая версия => 0.4.6
2009-11-20 15:22 heston_james Комментарий добавлен: 0000853
2009-11-20 16:39 skirsdeda Комментарий добавлен: 0000854
2009-11-24 15:20 heston_james Комментарий добавлен: 0000855
2009-11-26 18:57 skirsdeda Комментарий добавлен: 0000857
2010-03-16 11:56 heston_james Комментарий добавлен: 0001176
2010-03-16 13:42 skirsdeda Комментарий добавлен: 0001177
2010-03-17 14:00 heston_james Комментарий добавлен: 0001178
2013-03-27 18:23 mei Комментарий добавлен: 0001853
2013-03-27 18:54 skirsdeda Комментарий добавлен: 0001854
2013-03-27 19:01 mei Комментарий добавлен: 0001855
2013-03-27 19:06 mei Комментарий добавлен: 0001856
2013-03-27 19:07 mei Комментарий добавлен: 0001857
2013-03-27 19:12 skirsdeda Комментарий добавлен: 0001858
2013-03-27 19:21 mei Комментарий добавлен: 0001859
2013-03-27 19:33 mei Комментарий добавлен: 0001860
2013-03-27 19:38 mei Комментарий добавлен: 0001861
2013-03-27 20:18 skirsdeda Комментарий добавлен: 0001862
2013-03-28 12:21 mei Комментарий добавлен: 0001863
2013-03-28 19:30 skirsdeda Комментарий добавлен: 0001864
2013-03-29 01:38 mei Комментарий добавлен: 0001865
2013-03-29 01:38 mei Комментарий добавлен: 0001866

Комментарии
(0000853)
heston_james   
2009-11-20 15:22   
Hey Tadas,

After playing around with the latest SVN build this morning this is certainly a feature I'd like to see implemented as I think the timeout may cause issues with our application. We use the client side of ODS.

When implementing this would it be possible to have it so that the timeout can be set to '0' to disable the timeout feature so the connection remains open perminantly?

The reason this causes issues for us is because for instance, if we try to send a file to a Sony handset, and the user doesn't accept the message within 15 seconds the prompt remains on their screen however the connection has been dropped by ODS so when they finally do click 'accept' on the file, they get an error on the phone and the file is not sent.

I can understand the benefits for some people but for me being able to turn off the timeout would be helpful.

Heston
(0000854)
skirsdeda   
2009-11-20 16:39   
Ok, I understand why this would be useful for you. I'll definitely implement it.
(0000855)
heston_james   
2009-11-24 15:20   
Hey Tadas, that's great news. Tell me, is there any quick way for me to hack the source code to disable the time out feature? I'm keen to test the other bug fixes in the latest build but am unable to operate it in a live environment whilst it's timing out.

I took a look through the course code but couldn't find where it was defined.

Cheers,

Heston
(0000857)
skirsdeda   
2009-11-26 18:57   
Try deleting:
ods-obex.c (lines 151-152 and 247-248)
(0001176)
heston_james   
2010-03-16 11:56   
Hey Tadas,

Can we take a look at implementing something to look at this? I've really keen to use the latest ods build because of all the stability fixes you've been making however without being able to disable this timeout feature I cannot.

I've tried various things to remove the feature myself but keep getting compilation errors.

Thanks my man, I hope you're well!

Heston
(0001177)
skirsdeda   
2010-03-16 13:42   
I just have to find some time to work on this. It's the highest priority in my ods todo list:)
(0001178)
heston_james   
2010-03-17 14:00   
Great stuff Tadas,

I look forward to seeing it! I know how hard it can be to find the time for these kinds of things :-D

Heston
(0001853)
mei   
2013-03-27 18:23   
Has this feature being added into 0.4.6?
(0001854)
skirsdeda   
2013-03-27 18:54   
The development of ODS has been stalled for quite some time now. If you would be willing to supply a patch for this, we could integrate it. Otherwise, I don't think I can do it anytime soon because of general lack of time :)
(0001855)
mei   
2013-03-27 19:01   
I have tried to get the tarball for 0.4.6 and change the timeout in ods-obex.h, however, I am having difficulty running the make command in my Fedora 17 system (i.e. make return errors with undeclared variable in ods-logging.c and ods-logging.error). May I know whether the tarball will build in a Fedora system?
(0001856)
mei   
2013-03-27 19:06   
I am seeing timeout request error when trying to send any file larger than 20k from blueman and i suspect that this timeout of 15s that is being set is causing the issue?
(0001857)
mei   
2013-03-27 19:07   
Any help will be very much appreaciated!
(0001858)
skirsdeda   
2013-03-27 19:12   
I just tried on fedora 18. Compiles and runs just fine. What are the compilation errors on your system?
(0001859)
mei   
2013-03-27 19:21   
[root@COEXSYSTEST2 obex-data-server-0.4.6]# make
  GEN src/ods-manager-dbus-glue.h
  GEN src/ods-server-dbus-glue.h
  GEN src/ods-server-session-dbus-glue.h
  GEN src/ods-session-dbus-glue.h
make --no-print-directory all-am
  CC src/ods-bluez.o
  CC src/ods-usb.o
  CC src/ods-capabilities.o
  CC src/ods-common.o
  CC src/ods-error.o
src/ods-error.c: In function ‘ods_error_obexrsp2gerror’:
src/ods-error.c:147:8: error: ‘OBEX_RSP_REQUEST_TIME_OUT’ undeclared (first use in this function)
src/ods-error.c:147:8: note: each undeclared identifier is reported only once for each function it appears in
src/ods-error.c:175:8: error: ‘OBEX_RSP_NOT_MODIFIED’ undeclared (first use in this function)
src/ods-error.c:191:8: error: ‘OBEX_RSP_UNSUPPORTED_MEDIA_TYPE’ undeclared (first use in this function)
make[1]: *** [src/ods-error.o] Error 1
make: *** [all] Error 2
(0001860)
mei   
2013-03-27 19:33   
Have i done anything wrong here?
(0001861)
mei   
2013-03-27 19:38   
Will you be able to modify the timeout in ods-obex.h to 1500 and send me the obex-data-server binary?
(0001862)
skirsdeda   
2013-03-27 20:18   
OBEX_RSP_* constants are defined in openobex library. Have you installed openobex-devel correctly? runing ./configure should catch that I suppose..
(0001863)
mei   
2013-03-28 12:21   
I am now able to build the code but I am still facing the same problem where I am not able to transfer any file larger than 20k. From the obex log, I am seeing OBEX event: LINKERR(0x4), PUT(0x2), (null)(0x0)
/org/openobex/session3: EV_LINKERR
/org/openobex/session3: EV_ABORT
/org/openobex/session3: UNLOCK ods_session_send_file_ext
/org/openobex/session3: LOCK ods_session_disconnect
Sending CMD_DISCONNECT


Any idea?
(0001864)
skirsdeda   
2013-03-28 19:30   
Device specific bug, I would say. It is rejecting file or smth similar..
(0001865)
mei   
2013-03-29 01:38   
I am transfering the file from a laptop to another laptop using bluetooth. When I tried to tranfer the file from my phone to the laptop, it works with large file. I am using bluez 4.101.
(0001866)
mei   
2013-03-29 01:38   
I am transfering the file from a laptop to another laptop using bluetooth. When I tried to tranfer the file from my phone to the laptop, it works with large file. I am using bluez 4.101.