Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000215 [obex-data-server] General minor always 2009-10-22 04:02 2009-10-22 19:02
Reporter mikeyrb View Status public  
Assigned To skirsdeda
Priority normal Resolution fixed  
Status resolved   Product Version 0.4.5
Summary 0000215: USE_USB guards don't protect missing usb.h
Description Not entirely sure which package usb.h comes in, but in any case, I did configure with usb disabled and I get build errors because of usb.h. If you move '#ifdef USE_USB' above the includes (but below '#include "config.h"'), all is well.

This occurs in ods-usb.c and ods-usb.h.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000821)
skirsdeda (administrator)
2009-10-22 19:02

Fixed in svn. Thanks for bug report.

- Issue History
Date Modified Username Field Change
2009-10-22 04:02 mikeyrb New Issue
2009-10-22 19:01 skirsdeda Target Version => 0.4.6
2009-10-22 19:02 skirsdeda Note Added: 0000821
2009-10-22 19:02 skirsdeda Status new => resolved
2009-10-22 19:02 skirsdeda Fixed in Version => 0.4.6
2009-10-22 19:02 skirsdeda Resolution open => fixed
2009-10-22 19:02 skirsdeda Assigned To => skirsdeda


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker