Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000492 [obex-data-server] FTP minor always 2010-10-28 11:44 2010-10-29 12:06
Reporter nami View Status public  
Assigned To skirsdeda
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0000492: Client can create folder when server is set write denied
Description The server ftp service is set not allow devices to write/delete by Blueman,when client browses server, although create file and delete file operations are forbiddened,but client still can create folder on server folder.Is it a bug?
I think when server gets create folder request,server should check whether it allow write.
I write a patch to fix this problem. And I checked ,it worked well.
Additional Information
Tags No tags attached.
Attached Files ? file icon write_deny.patch [^] (2,478 bytes) 2010-10-28 11:44

- Relationships

-  Notes
(0001398)
skirsdeda (administrator)
2010-10-28 13:45

Yes, this is a bug in a sense. It was overlooked when introducing read-only support. Thanks for a patch!
(0001400)
skirsdeda (administrator)
2010-10-28 15:19

I commited a fix to svn. Had to rewrite the function a bit because there was a variable being used after freeing it. I would appreciate it if you could check if it still works OK and let me know. Thanks.
(0001401)
nami (reporter)
2010-10-29 05:39

Yeah,I checked your version ,it worked well on this bug.

- Issue History
Date Modified Username Field Change
2010-10-28 11:44 nami New Issue
2010-10-28 11:44 nami File Added: write_deny.patch
2010-10-28 13:43 skirsdeda Status new => assigned
2010-10-28 13:43 skirsdeda Assigned To => skirsdeda
2010-10-28 13:45 skirsdeda Note Added: 0001398
2010-10-28 15:19 skirsdeda Note Added: 0001400
2010-10-29 05:39 nami Note Added: 0001401
2010-10-29 12:06 skirsdeda Status assigned => resolved
2010-10-29 12:06 skirsdeda Resolution open => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker