Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000493 [obex-data-server] FTP crash always 2010-10-29 05:57 2011-02-14 00:22
Reporter nami View Status public  
Assigned To skirsdeda
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0000493: ftp client get server file ,cause server segmentation fault
Description hi,I found when ftp client get server file, the server will occur segmentation fault.The server ods log is below:


##DEBUG: /org/openobex/serversession0 OBEX event: STREAMEMPTY(0x8), CONNECT(0x0), (null)(0x0)
obex_writestream
writestream from Buffer
buf_size: 357, actual: 357
##DEBUG: /org/openobex/serversession0 OBEX event: STREAMEMPTY(0x8), CONNECT(0x0), (null)(0x0)
obex_writestream
writestream from Buffer
buf_size: 357, actual: 0
##DEBUG: /org/openobex/serversession0 OBEX event: REQDONE(0x3), GET(0x3), (null)(0x0)
io callback
##DEBUG: /org/openobex/serversession0 OBEX event: REQHINT(0x1), GET(0x3), (null)(0x0)
##DEBUG: /org/openobex/serversession0 OBEX event: REQ(0x2), GET(0x3), (null)(0x0)
CMD_GET requested
stream_fd=-1
Segmentation fault
nami@nami-laptop:~$

Do you have met this error?
I find this error is caused by client does not contain Type header in its first get request package,but the server side calls strcmp (obex_context->type, LST_TYPE) in ods_obex_srv_get function. Since obex_context->type is null ,so it causes segmentation fault.

A patch to fix this problem is attached. I checked ,it resolved this problem.


Additional Information
Tags No tags attached.
Attached Files ? file icon get.patch [^] (565 bytes) 2010-10-29 05:57

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2010-10-29 05:57 nami New Issue
2010-10-29 05:57 nami File Added: get.patch
2010-10-29 12:10 skirsdeda Status new => assigned
2010-10-29 12:10 skirsdeda Assigned To => skirsdeda
2011-02-14 00:22 skirsdeda Status assigned => resolved
2011-02-14 00:22 skirsdeda Fixed in Version => 0.4.6
2011-02-14 00:22 skirsdeda Resolution open => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker