Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000584 [obex-data-server] FTP crash always 2011-02-09 01:03 2011-02-14 00:22
Reporter afiestas View Status public  
Assigned To skirsdeda
Priority normal Resolution fixed  
Status resolved   Product Version 0.4.5
Summary 0000584: Crash when trying to CMD_GET because obex_context->type is null
Description Hi there

While implementing obexftp support in BlueDevil using obex-data-server I've noticed a crash which at least in my two environments is always reproducible and it happens just by trying to get a file, for example by executing:

obexftp -b 00:00:00:00:00:00 -g foo.txt

The bt is attached.

I've found the source of the crash, it happens at line 1028 of ods-obex.c because obex_context is assumed to exist but it is null, so when trying to use strcmp it crashes.

Even though that is the source of the crash, something else is wrong since obex_context->local is null too, so even if we patch the obex_context->type checking the function will end with a -1.

Additional Information
Tags No tags attached.
Attached Files txt file icon crash.txt [^] (1,618 bytes) 2011-02-09 01:03
txt file icon debug.txt [^] (3,644 bytes) 2011-02-09 01:04

- Relationships

-  Notes
(0001588)
skirsdeda (administrator)
2011-02-09 01:37

Please try with obex-data-server from subversion trunk. Let me know how it goes and nag me to fix this bug and make a release (I'm developing some Silverlight based stuff and don't see Linux on my desktop too much ATM :))
(0001589)
afiestas (reporter)
2011-02-09 02:01

Same bt and same crash with trunk (I forgot to say that).

I'm ready to test any patch you can provide.

Thanks!
(0001590)
skirsdeda (administrator)
2011-02-10 11:10

do svn update and try again.
(0001591)
afiestas (reporter)
2011-02-12 03:25

It seems to be working now, thanks!

- Issue History
Date Modified Username Field Change
2011-02-09 01:03 afiestas New Issue
2011-02-09 01:03 afiestas File Added: crash.txt
2011-02-09 01:04 afiestas File Added: debug.txt
2011-02-09 01:31 skirsdeda Status new => assigned
2011-02-09 01:31 skirsdeda Assigned To => skirsdeda
2011-02-09 01:37 skirsdeda Note Added: 0001588
2011-02-09 02:01 afiestas Note Added: 0001589
2011-02-10 11:10 skirsdeda Note Added: 0001590
2011-02-12 03:25 afiestas Note Added: 0001591
2011-02-14 00:22 skirsdeda Status assigned => resolved
2011-02-14 00:22 skirsdeda Fixed in Version => 0.4.6
2011-02-14 00:22 skirsdeda Resolution open => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker